A propos des MAJ et des versions de PHP ?

Image Tout ce qui est en rapport avec l'hébergement , codes , sites , blogs etc ...
Répondre
     

Auteur du sujet
nibik
Messages : 363
Enregistré le : octobre 2011
Hébergeur(s) : OVH

A propos des MAJ et des versions de PHP ?

Message par nibik » sam. 24 févr. 2018 16:07

Bonjour à tous,

J'ai été victime d'un virus sur mon blog wordpress, j'ai réussi à la neutraliser en faisant une MAJ wordpress. Mais il y a encore du boulot, notamment OVH m'indique que ma version de PHP et 4.4. Seulement voilà, mon forum phpbb est en version 3.0.13... Du coup je m'interroge ;
- comment connaitre les versions de php que ma version de phpbb 3.0.13 supporterait ? Genre si je passais en 5.6 par exemple ?
- en outre, si je souhaite faire évoluer ma version de phpbb, je peux télécharger directement la version 3.2.2 http://www.phpbb-fr.com/telechargements/ ou il faut faire évoluer version par version ?
- Enfin, si je fais évoluer mon version de phpbb, cela va impacter mes thèmes, mes mods j'imagine ? :roo:


Merci beaucoup pour vos retours à tous.

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10842
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: A propos des MAJ et des versions de PHP ?

Message par Steph » sam. 24 févr. 2018 18:51

Salut,

Pour phpBB 3.2.2 il faut au minimum PHP 5.4.7, idéalement PHP 7

Pour PHP 7, il faut obligatoirement une version 3.2.x.

Ta version phpBB 3.0.13 fonctionnera avec PHP 5.6.

La mise à niveau peut se faire directement de 3.0.13 à 3.2.2, mais cela demande une grosse réflection.

Les MOD tout comme les styles ne sont pas du tout compatibles avec phpBB 3.2.x.

Question support, c'est terminé pour la branche 3.0 depuis janvier 2017, pour la branche 3.1, elle aura droit au même sort à partir de juillet 2018.


Auteur du sujet
nibik
Messages : 363
Enregistré le : octobre 2011
Hébergeur(s) : OVH

A propos des MAJ et des versions de PHP ?

Message par nibik » dim. 25 févr. 2018 12:22

Merci Steph,

1. Le plus simple dans l'immédiat serait donc de passer ma version de php à 5.6. Dans OVH je vois que je peux le faire assez simplement mais j'imagine qu'il y a des chose à faire également sur mes fichiers phpbb ? Vérifier la comptabilité de mon thème ? des manips particulières ? Est-ce un prestation que vous proposez l'upgrade de php ?

2. Dans un second temps, accepteriez-vous de passer mon site de 3.0.13 à 3.2.2 ?

ps : vous connaissez un site équivalent au votre pour wordpress à tout hasard ?

Merci

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10842
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

A propos des MAJ et des versions de PHP ?

Message par Steph » dim. 25 févr. 2018 16:17

1. PhpBB sera compatible avec PHP 5.6 sans rien modifier, les seules soucis seraient éventuellement liés aux MOD s'ils ne sont pas codées en tenant compte de cette version de php

Au pire il faut tester avec une version PHP 5.4

2. Pour la mise à niveau c'est possible, mais nous ne pourrons pas porter le style ni créer des extensions en remplacement des MOD

Si le forum était une premod SEO, il n'existe pas de possibilité viable et fiable pour garder la réécriture des urls

Je ne connais pas d'équivalent PA pour WordPress


Auteur du sujet
nibik
Messages : 363
Enregistré le : octobre 2011
Hébergeur(s) : OVH

A propos des MAJ et des versions de PHP ?

Message par nibik » dim. 25 févr. 2018 17:39

Merci ! Encore une question, quelque chose m'échappe...

Sur OVH il est indiqué que la version PHP et 4.4, mais dans mon panneau admin dans "information php" de l'onglet général je vois Version de PHP : 5.2.17 ? A quoi correspond cette version ?

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10842
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: A propos des MAJ et des versions de PHP ?

Message par Steph » dim. 25 févr. 2018 18:48

Le mieux est encore de contacter OVH, car effectivement il y a deux informations différentes.


Auteur du sujet
nibik
Messages : 363
Enregistré le : octobre 2011
Hébergeur(s) : OVH

A propos des MAJ et des versions de PHP ?

Message par nibik » dim. 25 févr. 2018 20:05

Merci Steph, bonne soirée

Répondre

Retourner vers « Support Webmastering »