[Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Image Demande de support pour les mods indépendants de la base .
Règles du forum
Merci de respecter les règles de la section pour les titres :

[Nom du mod - Version] Description du problème .
Verrouillé

Auteur du sujet
ZePhYmA

[Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par ZePhYmA »

Bonjour,

Petit MOD sympa et pratique que celui-ci, mais malheureusement, après une installation sans problème, lorsque le menu se voit activé, le forum se déforme. Il n'y a que les fichiers suivant à modifier :
  • includes/constants.php,
  • includes/functions.php,
  • styles/prosilver/theme/stylesheet.css,
  • styles/prosilver/template/overall_header.html
C'est étrange par ce que sur mes anciennes installations de ce MOD, je n'ai eu aucun soucis, s'est la première fois. L'installation s'est bien passé et le thème, les templates, le pack d'image et la cache ont été rafraîchit après installation. Mais visiblement, la largeur du forum s'étend, et le fond blanc disparaît... Le style s'est pas encore ma tasse de thé :euh:

Pour comparer :

Image Image

[centrer][/centrer]

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 12001
Enregistré le : 19 avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par Steph »

Salut,

Attends de réglé l'autre souci que tu as car il y a surement un conflit entre les 2

Auteur du sujet
ZePhYmA

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par ZePhYmA »

Oui, à mon avis :roo:
Avatar du membre

EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8662
Enregistré le : 19 avril 2010
Hébergeur(s) : Monarobase
Localisation : Au soleil
Contact :

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par EnYgmA »

installe les mods sur prosilver sur un forum test ainsi tu sauras qui est le responsable ( les mods ou le style ) :clin:
Très absent en ce moment ...
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

Auteur du sujet
ZePhYmA

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par ZePhYmA »

Salut,

Je viens de tester et je n'ai pas de problème sur le style prosilver, et sur le style spécial edition prosilver hmmmm
Ce n'est pas le mod, donc bel et bien mon style ?

Par ce que en faite, je remarque que lorsque j'active le menu, mon forum se déforme, seulement à partir de la fin de mon logo (image header), et comme s'est pile là qu'est placé le menu, s'est peut-être du à l'histoire de mon <div id="page-header"> qui se ferme avec le début du mod button menu... Voir ce que j'ai écrit dans ce post. :roo:

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 12001
Enregistré le : 19 avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par Steph »

Revient en arrière et recommence !

Sinon ton forum est-il beaucoup modé ?

Si non reprends une archive originale et récupère les fichiers au pire même si tu as beaucoup de MOD tu peux d'une part le mettre à jour en dernière version et d'autre part apuré le code

Auteur du sujet
ZePhYmA

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par ZePhYmA »

Salut,

Oui, mon forum est très modé :cool: Mais s'est sur et certains, s'est le problème lié avec le page body ou page-header

En bidouillant un peu, j'ai obtenu un meilleur résultat, il ne manque plus que le fond blanc hmmmm
Sa donne cela :
Image


Edit : Voici mon fichier overall_header.html | Télécharger
Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : 27 décembre 2010

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par zach »

salut

il faudrait que le prb soit visible pour tester, active le mod

il y a de grandes chances que ce soit un prb de div ...
<!-- IF S_MENU_ENABLED -->
<span class="corners-bottom" style="height:0px;"><span></span></span></div>
</div>

<div id="menu" style="clear:both;<!-- IF S_MENU_MARGIN -->margin-top: -3px;<!-- ELSE -->margin-top: -4px;<!-- ENDIF -->;background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_bg.gif') repeat-x;">
<div class="inner">
Le mod ferme des div au début, sauf que sur ton forum elles sont de trop, et les 2 autres div du mod ne sont pas fermées

Auteur du sujet
ZePhYmA

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par ZePhYmA »

Salut,

J'ai déjà testé le MOD, je vous ai donné un screen. Tu as vraiment besoin que j'active le MOD ?
Sinon pour les div s'est exactement ce que je pensais, sauf que je ne savais pas comment le dire, donc sa voudrais dire qu'il faudrait faire des aménagement ? S'est justement en retirant les 2 </div> du debut du MOD que je suis arrivé à mon 2ème screen (plus haut) ou il ne manquait plus que le fond blanc et ses "lignes rouges" sur le côté.
Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : 27 décembre 2010

Re: [Buttons menu 1.1.0] Le forum se déforme, quand le menu est activé !

Message par zach »

tu peut essayer de supprimer :

Code : Tout sélectionner

<span class="corners-bottom" style="height:0px;"><span></span></span></div>
</div>
et tu ajoute :

Code : Tout sélectionner

</div></div>
juste avant la fin de ce bout de code ajouté par le mod (juste avant le dernier <!-- ENDIF -->)
Verrouillé
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Mods indépendants de la base »